Taxi Driver Online

UK cab trade debate and advice
It is currently Sat Aug 24, 2019 1:18 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Tue Oct 06, 2015 4:26 pm 
Offline

Joined: Thu May 26, 2005 7:33 pm
Posts: 1117
Location: City of dreaming spires
Hello I've had the EGR VAlve changed on my tx4, we've changed the two solenoids, the pipe, blasted it through with a vacuum and the engine management light is still on with the code P0402.

I've also changed the MAF and I'm out of ideas? Admittedly it runs better with the new egr, but it'll fail the mot with the light on.,,

So does anyone have any idea as to what the fault could be?


Top
 Profile  
 
PostPosted: Tue Oct 06, 2015 5:20 pm 
Offline
User avatar

Joined: Mon Mar 21, 2005 8:44 pm
Posts: 10476
Location: Scotland
187ums wrote:
Hello I've had the EGR VAlve changed on my tx4, we've changed the two solenoids, the pipe, blasted it through with a vacuum and the engine management light is still on with the code P0402.

I've also changed the MAF and I'm out of ideas? Admittedly it runs better with the new egr, but it'll fail the mot with the light on.,,

So does anyone have any idea as to what the fault could be?


http://www.obd-codes.com/p0402


Top
 Profile  
 
PostPosted: Tue Oct 06, 2015 10:12 pm 
Offline

Joined: Tue Oct 18, 2011 7:36 pm
Posts: 810
skippy41 wrote:
187ums wrote:
Hello I've had the EGR VAlve changed on my tx4, we've changed the two solenoids, the pipe, blasted it through with a vacuum and the engine management light is still on with the code P0402.

I've also changed the MAF and I'm out of ideas? Admittedly it runs better with the new egr, but it'll fail the mot with the light on.,,

So does anyone have any idea as to what the fault could be?


http://www.obd-codes.com/p0402


Looks like the DPF sensor then. (differential pressure sensor not diesel particulate filter)


Top
 Profile  
 
PostPosted: Tue Oct 06, 2015 10:40 pm 
Offline

Joined: Thu May 26, 2005 7:33 pm
Posts: 1117
Location: City of dreaming spires
Thanks but I don't think TX4"s have that, mine is an 09 and we've changed all the obvious stuff ...


Top
 Profile  
 
PostPosted: Fri Oct 09, 2015 9:04 pm 
Offline

Joined: Tue Oct 18, 2011 7:36 pm
Posts: 810
Have you sorted it yet ?


Top
 Profile  
 
PostPosted: Fri Oct 09, 2015 9:38 pm 
Offline

Joined: Thu May 26, 2005 7:33 pm
Posts: 1117
Location: City of dreaming spires
It comes off every now and again, the mechanic will have another look soon. He suspects it may be a dodgy wire or the vacuum pump.

The funny thing is if it's been on up on a ramp, the light stays off for while....


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group