Taxi Driver Online

UK cab trade debate and advice
It is currently Sun May 28, 2017 7:34 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Help TX4 electric fault
PostPosted: Sun May 07, 2017 6:38 pm 
Offline

Joined: Sat May 06, 2017 10:56 pm
Posts: 3
Hi Guys

Wondering if anyone can help, got a strange fault with my 2009 tx4 auto
dip beam lights/interior lights/intercom have stopped working
even though intercom light comes on when switch is on
just no sound & side/main beam also work just no dip beam

i have checked all fuses in passenger compartment/engine bay near battery
which are ok, is there any other fuse/relays that i can check ?
thanks in advance.


Top
 Profile  
 
PostPosted: Fri May 19, 2017 6:10 pm 
Offline

Joined: Tue Jan 10, 2017 3:03 pm
Posts: 7
This is a strange one,I've just checked the schematics for the circuits you're having problems with and the only common denominator for the three is that they all seem to connected to fuse F20 20amp, apart from that the only other factor may be the CCU, hope this helps.
If it helps I could email copies of the schematics to you if you let me have an email addy.


Top
 Profile  
 
PostPosted: Sun May 21, 2017 10:31 pm 
Offline

Joined: Sat May 06, 2017 10:56 pm
Posts: 3
thinwhiteduke wrote:
This is a strange one,I've just checked the schematics for the circuits you're having problems with and the only common denominator for the three is that they all seem to connected to fuse F20 20amp, apart from that the only other factor may be the CCU, hope this helps.
If it helps I could email copies of the schematics to you if you let me have an email addy.


Hi, thanks for reply, i think it is the massie ccu box, as ive checked all fuses etc
if i tap the ccu the faulty circuits start to work for few mins then off again
do you know if all tx4 ccu are plug/play ? my tx4 is 2009 auto
wonder if ccu is repairable ?


Top
 Profile  
 
PostPosted: Mon May 22, 2017 5:37 pm 
Offline

Joined: Tue Jan 10, 2017 3:03 pm
Posts: 7
I've changed a couple in the past and both times they were plug and play but both were auto's not sure if a manual one would work, by you tapping it and it starting to work briefly it sounds like it may have a dry/bad joint inside, there is a place in the london area who repair these kinds of automotive ecu's whether they do the taxi parts I dont know I'll try and dig their number out it cant hurt to give them a ring, they have a very fast turnaround.


Top
 Profile  
 
PostPosted: Tue May 23, 2017 2:12 am 
Offline

Joined: Sat May 06, 2017 10:56 pm
Posts: 3
thinwhiteduke wrote:
I've changed a couple in the past and both times they were plug and play but both were auto's not sure if a manual one would work, by you tapping it and it starting to work briefly it sounds like it may have a dry/bad joint inside, there is a place in the london area who repair these kinds of automotive ecu's whether they do the taxi parts I dont know I'll try and dig their number out it cant hurt to give them a ring, they have a very fast turnaround.



check your pm please :D


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group