Taxi Driver Online
http://www.taxi-driver.co.uk/phpBB2/

Low on power
http://www.taxi-driver.co.uk/phpBB2/viewtopic.php?f=9&t=30409
Page 1 of 1

Author:  LondonCabbie7861 [ Mon Dec 12, 2016 9:11 am ]
Post subject:  Low on power

If it's not one thing it's another :( The Cabs driving really low on power as if it's gone into limp mode,on ocassions I get load of smoke coming out the exhaust when I go up a hill,and on load,coil light flashed a few times and Cabs stalled,struggles on full load anyone have any ideas?

Author:  Chris the Fish [ Mon Dec 12, 2016 11:52 am ]
Post subject:  Re: Low on power

Just a chance that an air filter change may help.

Wasn't a Cab but a diesel Galaxy I had many years ago was the same symptoms. Air filter blocked with leaves (and powdered leaves) so a simple filter change sorted it.

Author:  LondonCabbie7861 [ Mon Dec 12, 2016 8:03 pm ]
Post subject:  Re: Low on power

The filter is absolutely filthy,put a new filter on today,there's a hole on the filter box personally i think there's a bit missing,as it's just sucking in air and everything else!

Author:  Chris the Fish [ Mon Dec 12, 2016 10:36 pm ]
Post subject:  Re: Low on power

So, is it working better?

Author:  sasha [ Mon Dec 12, 2016 11:32 pm ]
Post subject:  Re: Low on power

What make/model of vehicle ?
Sounds like it may be the turbo if it has one, or a split in an air hose. The symptoms point to some sort of air intake problem, turbo, hoses, mass airflow sensor, filter.

Let us know how you get on, might help others to know.

Author:  LondonCabbie7861 [ Sat Dec 17, 2016 10:12 am ]
Post subject:  Re: Low on power

No it hasn't fixed it,drives really flat as if the Turbo is not kicking in, had it on diagnostic machine and these codes came up,It's a Tx2 2002 it's beginning to Stall occasionally, engine noise changes just before it stallls as similar to an exhaust blown re start it and drives but still flat as a pancake.

P1666 injection pump control module
P0149 Fuel Timing Error
P1563 Injection Pump Control Module requesting engine stop
P1564 injection pump control module requesting reduced fuelling
P1664 injection pump control module malfunction
P0335 Crankshaft position sensor A circuit.

Any help Appreciated

Author:  grandad [ Sat Dec 17, 2016 10:46 am ]
Post subject:  Re: Low on power

LondonCabbie7861 wrote:
No it hasn't fixed it,drives really flat as if the Turbo is not kicking in, had it on diagnostic machine and these codes came up,It's a Tx2 2002 it's beginning to Stall occasionally, engine noise changes just before it stallls as similar to an exhaust blown re start it and drives but still flat as a pancake.

P1666 injection pump control module
P0149 Fuel Timing Error
P1563 Injection Pump Control Module requesting engine stop
P1564 injection pump control module requesting reduced fuelling
P1664 injection pump control module malfunction
P0335 Crankshaft position sensor A circuit.

Any help Appreciated

I would start with the cheap and simple. I would change the crankshaft sensor. If this is giving a false reading that could explain the timing error.

Author:  MR T [ Sat Dec 17, 2016 5:51 pm ]
Post subject:  Re: Low on power

I know you will have..but I will ask..have you changed the fuel filter...

Author:  sasha [ Sat Dec 17, 2016 6:38 pm ]
Post subject:  Re: Low on power

A crankshaft sensor is only around £15. The fault codes seem to suggest a problem with the injection pump or control module but the problem may lie elsewhere.

If there's not enough air getting into the system the pump control module will sense this and throw out the error codes. I'd start by making sure all hoses are attached and there's no cracks or splits in them, then change the crankshaft sensor, then swap the mass airflow sensor, then get the control module checked and finally test the injection pump. Try each in order and see if the problem goes.

I had a split in a turbo hose and it went to about 50% power.
When my injector pump went the engine would cut out if you floored it or tried to go above 60mph and the coil light would come on, but it had done over 300k miles by that time. Unlikely for the pump itself to have failed unless a very high mileage, more likely for the control module to fail.

Author:  LondonCabbie7861 [ Sun Dec 18, 2016 12:32 am ]
Post subject:  Re: Low on power

Thanks for all the advice guys appreciate it, I've changed the crankshaft sensor,changed fuel filter,cleared the codes drove lovely for a short time then went back into limp mode,put the diagnostic machine back on and the same fault codes came up as listed above,

Author:  MR T [ Sun Dec 18, 2016 8:48 am ]
Post subject:  Re: Low on power

Does it start easily..?

Author:  LondonCabbie7861 [ Sun Dec 18, 2016 10:21 am ]
Post subject:  Re: Low on power

Cold start takes a couple of attempts after that it's fine,just runs really low on power.

Author:  MR T [ Mon Dec 19, 2016 5:30 pm ]
Post subject:  Re: Low on power

LondonCabbie7861 wrote:
Cold start takes a couple of attempts after that it's fine,just runs really low on power.

When was the last time it had a timing chain..

Author:  LondonCabbie7861 [ Fri Dec 30, 2016 12:14 am ]
Post subject:  Re: Low on power

Timing chain was done in September,

Page 1 of 1 All times are UTC - 1 hour [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/